Dirty Windshield Mod + Realistic Lighting + Lens Flare v1.0

Date 2016-04-07 09:13

dirty-2
dirty
wash

This is a graphic mod for American Truck Simulator, it includes many features such as realistic windshield (dirt and scratches), realistic lighting + effects like lens flare making American Truck Simulator as realistic as possible.

Features:

– Dirty Windshield + adjustment tool.
– Lens Flare Effect.
– More Sharpness.
– SMAA anti-Aliasing.
– Realistic Lighting/Colors.

– Using the Windshield tool :

It is recommended to run the tool as an administrator and to have Java up to date.

You need to set the windshield for each interior by using the simple tool provided, just choose your current interior and see the result directly in the game without restarting it.

— Installation :
Extract the 5 files into American Truck Simulator/bin/win_x64

– Uninstall:
Remove the 5 files from American Truck Simulator/bin/win_x64

– Future work :

* More dirt/scratches/wet templates, and the possibility to choose one among many.
* More interiors
* Custom cracks/spots on the windshield on custom positions.
* More lens flare textures and the possibility to choose the preferred one.

Support by Subscribing and liking, your feedback is important.

Enjoy !

Credits:
TheBen

DOWNLOAD 14.4 MB

43 Responses to Dirty Windshield Mod + Realistic Lighting + Lens Flare v1.0

  1. Would this work with any modded truck for example Volvo VNL 670??

  2. BahamutX

    good work man at least someone is trying to add something like this NO thanks to those lazy SCS they could of added it the first place.lol

  3. putut

    when right click on whinshield.exe why show this message a bundled a java runtime environment but runtime is missing or corrupted,can help about this error?

  4. henkie w

    no scs-file ?

    do it need to bein a EXE-file.

  5. @TheBen
    First of all, thank you for this mod.

    I have some questions and issues:
    1. I’ve put the files into my game folder. Mod have been activated (changed color-in the menu and in game- automatically.). I’m trying to open the tool BEFORE opening the game (run as admin/java is updated), but doesn’t open in the first place.
    2. How do i see it IN the game? In your youtube video, you’re doing everything too fast. What have you done and the tool popped up in game? Did you press a button or something?
    3. Will this mod make a FPS drop ?

    Thank in advance.

  6. Nicklas Olsson

    Nope, tried everything I can come up with, don’t work!! =(

    • What doesn’t work ?

      • Nicklas Olsson

        Followed you installation to the letter. Even allowed the .exe file thru the firewall. And finally re-bind the “scroll-lock” button to another hotkey (F11) and punched that button 511 time in game, nothing.

        1. Admin startup Windshield.exe
        2. Admin startup amtrucks.exe
        3. When in game, (Kenworth T680) “ALT Tab”to Windshield.exe, select Kenworth 1 and then press “Yes” and “OK”
        4. ALT Tab back to game, press “Scroll-lock”
        5. Nothing happens =( What’s wrong?

        =(

  7. Goosy

    The colors with his mod look really bad. :(

    • where did you read beautifull un-realistic color somewhere ???

      in fact those color are made to look real ! not beautifull ! it may also depend on your monitor ?! who knows ….

      Of course the color in menu may seems off, its a hooker, XD lol but it is. It bypass your output and filter it with an aditional direct X filters… it doesnt know what is the menu and what is the game, so in menu it dosnt look that good, but in-game it looks stunning

      Took a couple of screenshot myself and with almost no photo shop, they look IRL photos !

      Good job Theben :)

      Cant wait to try your dirty windshield :)
      I supose you have a windshild for the W900 in those ?! :P

      Thx for sharing your work :)

  8. seems great thanks for video!

  9. luis

    hi i am trying to install and I can not , not if you can direct me to instarlarlo I’d appreciate it wholeheartedly thanks

  10. hello TheBen

    Dont know what changed in the hook, but now neither this version or my previous version of crossire reshaders works ….

    Starting MP just give me a black screen with sound…
    and starting normal single player make ATS appears in task manager consuming 3.7mb of ram >>> in background processes… 0 % CPU

    nothing else…. if i try to double open it, steams tell me that im already in the game….

    i need to froce close the dead end ATS.exe task … if i remove the shaders, everything works again …

    here the dx9 hooking log :

    07/04/2016 23:56:01:400 [14204] | INFO | Initializing Crosire’s ReShade version ‘1.0.0.916’ built on ‘2015-08-10 01:54:08’ loaded from “D:\Games Files (x86)\Steam Games\steamapps\common\American Truck Simulator\bin\win_x64\d3d9.dll” to “D:\Games Files (x86)\Steam Games\steamapps\common\American Truck Simulator\bin\win_x64\amtrucks.exe” …
    07/04/2016 23:56:01:485 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d8.dll” …
    07/04/2016 23:56:01:485 [14204] | INFO | > Delayed.
    07/04/2016 23:56:01:485 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d9.dll” …
    07/04/2016 23:56:01:485 [14204] | INFO | > Delayed.
    07/04/2016 23:56:01:485 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d10.dll” …
    07/04/2016 23:56:01:519 [14204] | INFO | > Delayed.
    07/04/2016 23:56:01:519 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d10_1.dll” …
    07/04/2016 23:56:01:519 [14204] | INFO | > Delayed.
    07/04/2016 23:56:01:519 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d11.dll” …
    07/04/2016 23:56:01:519 [14204] | INFO | > Delayed.
    07/04/2016 23:56:01:519 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\dxgi.dll” …
    07/04/2016 23:56:01:519 [14204] | INFO | > Libraries loaded.
    07/04/2016 23:56:01:519 [14204] | INFO | > Found 7 match(es). Installing …
    07/04/2016 23:56:01:603 [14204] | ERROR | Failed to install hook for ‘0x00007FFE81302C40’ with status code 3.
    07/04/2016 23:56:01:624 [14204] | ERROR | Failed to install hook for ‘0x00007FFE81302C40’ with status code 3.
    07/04/2016 23:56:01:624 [14204] | INFO | > Installed 5 hook(s).
    07/04/2016 23:56:01:624 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\opengl32.dll” …
    07/04/2016 23:56:01:624 [14204] | INFO | > Libraries loaded.
    07/04/2016 23:56:01:627 [14204] | INFO | > Found 360 match(es). Installing …
    07/04/2016 23:56:09:025 [14204] | INFO | > Installed 360 hook(s).
    07/04/2016 23:56:09:026 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\user32.dll” …
    07/04/2016 23:56:09:026 [14204] | INFO | > Libraries loaded.
    07/04/2016 23:56:09:036 [14204] | INFO | > Found 5 match(es). Installing …
    07/04/2016 23:56:09:138 [14204] | INFO | > Installed 5 hook(s).
    07/04/2016 23:56:09:138 [14204] | INFO | Registering hooks for “C:\WINDOWS\system32\ws2_32.dll” …
    07/04/2016 23:56:09:138 [14204] | INFO | > Libraries loaded.
    07/04/2016 23:56:09:140 [14204] | INFO | > Found 8 match(es). Installing …
    07/04/2016 23:56:09:309 [14204] | INFO | > Installed 8 hook(s).
    07/04/2016 23:56:09:309 [14204] | INFO | Initialized.

    I, myself are good at computer, i tried re-installing java, run registry fixer, re-install dx9 but win10 dx12 wont allow me to do so, and i know force installing an older standalone version of direct x could gimme headaches in future ….

    what happenned ! yesterday all was great and smooth … now it wont work either on this version or the past version of the shaders, either on single player or multiplayer …. Surely not the shaders itself since it worked before… seems to have an error in hook process

    here is the ats log past the mods and setting initialization where everything seems fine above it…

    00:00:00.521 : [lang] Language autodetection: 409
    00:00:00.529 : Selected language: en_us
    00:00:00.530 : American Truck Simulator init ver.1.1.1.3s (rev. d3f6ead39fcf)
    00:00:00.556 : [net] LOG INFO: Started
    00:00:00.566 : Setting UI reference mode to: 1440×900…
    00:00:00.566 : Render device override: dx9
    00:00:00.566 : [gfx] Selected rendering device: dx9
    00:00:00.586 : [dx9] NVAPI initialized
    00:00:00.641 : [dx9] Direct3D9Ex detected.
    00:00:00.641 : [dx9] Number of adapters found: 1
    00:00:00.675 : [dx9] Adapter #0: NVIDIA GeForce GTX 780 Ti / 2048 (0) MB (nvd3dumx.dll, 10.18.13.6472, )
    00:00:00.675 : [dx9] Using adapter #0.
    00:00:00.678 : [dx9] Using SM3X rendering path
    00:00:00.679 : [gfx] Trying to set 5760×1080 32bpp 60Hz (fullscreen)
    00:00:00.847 : [dx9] SLI not found.
    00:00:00.847 : [dx9] Stereo fully allowed.
    00:00:00.847 : [dx9] Unable to initialize stereo (-140), the stereo driver might be not installed
    00:00:00.847 : [dx9] D3D9 device sucessfully created [HWVP]
    00:00:01.820 : [al] device: OpenAL Soft
    00:00:01.820 : [al] context extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_loopback
    00:00:01.840 : [al] vendor: OpenAL Community
    00:00:01.840 : [al] version: 1.1 ALSOFT 1.14
    00:00:01.840 : [al] renderer: OpenAL Soft
    00:00:01.840 : [al] extensions: AL_EXT_ALAW AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFTX_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points
    00:00:01.840 : [snd] Started sound update thread
    00:00:01.893 : [di8] Initializing device ‘@@keyboard@@’ as ‘keyboard’
    00:00:01.895 : [di8] Initializing device ‘@@i_mouse@@’ as ‘mouse’
    00:00:01.914 : [di8] Initializing device ‘MotioninJoy Virtual Game Controller’ as ‘{6182E4C0-51CA-11E5-8003-444553540000}|{03088888-0000-0000-0000-504944564944}’
    00:00:01.915 : [di8] FF Constant force supported
    00:00:01.915 : [di8] FF Ramp force supported
    00:00:01.915 : [di8] FF Square force supported
    00:00:01.915 : [di8] FF Sine force supported
    00:00:01.915 : [di8] FF Triangle force supported
    00:00:01.915 : [di8] FF SawtoothUp force supported
    00:00:01.915 : [di8] FF SawtoothDown force supported
    00:00:01.915 : [di8] FF Spring force supported
    00:00:01.915 : [di8] FF Damper force supported
    00:00:01.915 : [di8] FF Inertia force supported
    00:00:01.915 : [di8] FF Friction force supported
    00:00:01.916 : [di8] FF Axis ‘x’ ‘X axis’ reports force 10N with resolution of 256
    00:00:01.916 : [di8] FF Axis ‘y’ ‘Y axis’ reports force 10N with resolution of 256
    00:00:01.917 : [di8] Initializing device ‘Logitech G13 Joystick’ as ‘{3139D260-5198-11E5-8003-444553540000}|{C2AB046D-0000-0000-0000-504944564944}’
    00:00:01.917 : [di8] Initializing device ‘Logitech Driving Force GT USB’ as ‘{73D6A0B0-DD86-11E5-8003-444553540000}|{C29A046D-0000-0000-0000-504944564944}’
    00:00:01.918 : [di8] FF Constant force supported
    00:00:01.918 : [di8] FF Ramp force supported
    00:00:01.918 : [di8] FF Square force supported
    00:00:01.918 : [di8] FF Sine force supported
    00:00:01.918 : [di8] FF Triangle force supported
    00:00:01.918 : [di8] FF SawtoothUp force supported
    00:00:01.918 : [di8] FF SawtoothDown force supported
    00:00:01.918 : [di8] FF Spring force supported
    00:00:01.918 : [di8] FF Damper force supported
    00:00:01.918 : [di8] FF Inertia force supported
    00:00:01.918 : [di8] FF Friction force supported
    00:00:01.919 : [di8] FF Axis ‘x’ ‘Wheel axis’ reports force 10N with resolution of 256
    00:00:02.333 : [hashfs] dlc_kenworth_t680.scs: Mounted and validated, 803 entries (10248971F14F99CAA44EDB0E8C2877AF64FC8C6516ABAD20ABB173EB4F54EF4)
    00:00:02.607 : [hashfs] dlc_kenworth_w900.scs: Mounted and validated, 872 entries (BB636C5A3732571D27F1DFF623BDEC1D88CE83BE8ED28D0DF38144236F7DFED)
    00:00:02.963 : [hashfs] dlc_nevada.scs: Mounted and validated, 650 entries (50E662D0BA13F29B288BB357319F2DB431CBA66A3301A1F1D6B6A6B475AE78B)
    00:00:03.129 : [hashfs] dlc_peterbilt_579.scs: Mounted and validated, 818 entries (FA15D0981407DE943325C7E346439F6F312414ADCF0CD9F79DE2E0BB47F2CB5)
    00:00:03.161 : [hashfs] dlc_steampunk.scs: Mounted and validated, 57 entries (6B3E1D5F2F168B8897241889394B5C8DDF9EC0B7D692BA1FAF3D91EF36AE381)
    00:00:51.792 : dispatch
    00:00:51.792 : exit

    i tought you could help me sort out my problem :) TYVM TheBen

    • interesting thing is when i try to froce start with direct x from the pop up menu when i click start on steam

      i got the black screen with the overlay : loading shaders … takes 20 seconds (way longer than usual) and i see the scs logo for a fraction of second, then it says initialization seucessfull, and the image goes black with sound … just like in MP

      HMMM ?!?!?!!

      here is the d3d9 log now :

      08/04/2016 00:12:06:154 [07196] | INFO | Initializing Crosire’s ReShade version ‘1.0.0.916’ built on ‘2015-08-10 01:54:08’ loaded from “D:\Games Files (x86)\Steam Games\steamapps\common\American Truck Simulator\bin\win_x64\d3d9.dll” to “D:\Games Files (x86)\Steam Games\steamapps\common\American Truck Simulator\bin\win_x64\amtrucks.exe” …
      08/04/2016 00:12:06:225 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d8.dll” …
      08/04/2016 00:12:06:225 [07196] | INFO | > Delayed.
      08/04/2016 00:12:06:225 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d9.dll” …
      08/04/2016 00:12:06:225 [07196] | INFO | > Delayed.
      08/04/2016 00:12:06:225 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d10.dll” …
      08/04/2016 00:12:06:225 [07196] | INFO | > Delayed.
      08/04/2016 00:12:06:225 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d10_1.dll” …
      08/04/2016 00:12:06:225 [07196] | INFO | > Delayed.
      08/04/2016 00:12:06:226 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\d3d11.dll” …
      08/04/2016 00:12:06:226 [07196] | INFO | > Delayed.
      08/04/2016 00:12:06:226 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\dxgi.dll” …
      08/04/2016 00:12:06:226 [07196] | INFO | > Libraries loaded.
      08/04/2016 00:12:06:226 [07196] | INFO | > Found 7 match(es). Installing …
      08/04/2016 00:12:06:314 [07196] | ERROR | Failed to install hook for ‘0x00007FFE81302C40’ with status code 3.
      08/04/2016 00:12:06:332 [07196] | ERROR | Failed to install hook for ‘0x00007FFE81302C40’ with status code 3.
      08/04/2016 00:12:06:332 [07196] | INFO | > Installed 5 hook(s).
      08/04/2016 00:12:06:332 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\opengl32.dll” …
      08/04/2016 00:12:06:332 [07196] | INFO | > Libraries loaded.
      08/04/2016 00:12:06:335 [07196] | INFO | > Found 360 match(es). Installing …
      08/04/2016 00:12:12:193 [07196] | INFO | > Installed 360 hook(s).
      08/04/2016 00:12:12:193 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\user32.dll” …
      08/04/2016 00:12:12:193 [07196] | INFO | > Libraries loaded.
      08/04/2016 00:12:12:204 [07196] | INFO | > Found 5 match(es). Installing …
      08/04/2016 00:12:12:288 [07196] | INFO | > Installed 5 hook(s).
      08/04/2016 00:12:12:288 [07196] | INFO | Registering hooks for “C:\WINDOWS\system32\ws2_32.dll” …
      08/04/2016 00:12:12:288 [07196] | INFO | > Libraries loaded.
      08/04/2016 00:12:12:290 [07196] | INFO | > Found 8 match(es). Installing …
      08/04/2016 00:12:12:424 [07196] | INFO | > Installed 8 hook(s).
      08/04/2016 00:12:12:424 [07196] | INFO | Initialized.
      08/04/2016 00:12:12:426 [02024] | INFO | Installing delayed hooks for “C:\WINDOWS\system32\d3d9.dll” …
      08/04/2016 00:12:12:426 [02024] | INFO | > Found 9 match(es). Installing …
      08/04/2016 00:12:12:426 [02024] | INFO | > Installed 9 hook(s).
      08/04/2016 00:12:14:432 [07196] | INFO | Redirecting ‘RegisterClassW(00007FF798BE6250)’ …
      08/04/2016 00:12:14:457 [07196] | INFO | Redirecting ‘Direct3DCreate9Ex(32, 0000028D6E0DE9E8)’ …
      08/04/2016 00:12:14:524 [07196] | INFO | Redirecting ‘CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 000000C50D71F0D8)’ …
      08/04/2016 00:12:14:528 [07196] | INFO | Redirecting ‘CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 000000C50D71F1F0)’ …
      08/04/2016 00:12:14:567 [07196] | INFO | Redirecting ‘IDirect3D9Ex::CreateDeviceEx(0000028D6E0C3FA0, 0, 1, 0000000000070DCA, 0x52, 000000C50D71F4D0, 000000C50D71F410, 0000028D6E0DE9F8)’ …
      08/04/2016 00:12:14:737 [07196] | INFO | Recreated effect environment on runtime 0000028D6E089C20.
      08/04/2016 00:12:29:798 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A70, 1, 16)’ …
      08/04/2016 00:12:29:798 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A40, 1, 16)’ …
      08/04/2016 00:12:29:798 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A20, 1, 16)’ …
      08/04/2016 00:12:29:798 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A10, 1, 16)’ …
      08/04/2016 00:12:31:669 [07196] | INFO | Loading effect from “D:\Games Files (x86)\Steam Games\steamapps\common\American Truck Simulator\bin\win_x64\ReShade.fx” …
      08/04/2016 00:12:31:763 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A70, 1, 16)’ …
      08/04/2016 00:12:31:763 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A40, 1, 16)’ …
      08/04/2016 00:12:32:997 [07196] | INFO | > Successfully compiled effect.
      08/04/2016 00:12:33:106 [07196] | INFO | > Resizing image data for texture ‘texSprite’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:33:393 [07196] | INFO | > Resizing image data for texture ‘texNoise’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:33:687 [07196] | INFO | > Resizing image data for texture ‘texFCS’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:33:957 [07196] | INFO | > Resizing image data for texture ‘texFSS’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:34:233 [07196] | INFO | > Resizing image data for texture ‘texFDS’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:34:517 [07196] | INFO | > Resizing image data for texture ‘texMask’ from 1920×1080 to 5760×1080 …
      08/04/2016 00:12:39:256 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A20, 1, 16)’ …
      08/04/2016 00:12:39:256 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A10, 1, 16)’ …
      08/04/2016 00:12:39:257 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A70, 1, 16)’ …
      08/04/2016 00:12:39:257 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A40, 1, 16)’ …
      08/04/2016 00:12:39:257 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A10, 1, 16)’ …
      08/04/2016 00:12:39:257 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A40, 1, 16)’ …
      08/04/2016 00:12:42:856 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A20, 1, 16)’ …
      08/04/2016 00:12:42:856 [07196] | INFO | Redirecting ‘RegisterRawInputDevices(00007FFE5FF91A10, 1, 16)’ …
      08/04/2016 00:12:42:857 [07196] | INFO | Destroyed effect environment on runtime 0000028D6E089C20.
      08/04/2016 00:12:44:483 [07196] | INFO | Exiting …
      08/04/2016 00:12:44:483 [07196] | INFO | Uninstalling 397 hook(s) …
      08/04/2016 00:12:51:901 [07196] | INFO | Exited.

      • no problem at all with sweet fx ?!!?!? weird thing O_o

        • Hi there, When you disable Reshade with the Scroll key, does the picture come back or does it stay black ?

          • no matter what i do now it wont open !

            Stays in windows background process.

            I really suspect it is the hook that is corrupted somehow and having an hard time starting properly…. thats why i was wondering if you could help me ! seems like a windows problem rather than your works problem….

            Maybe something you know about it to reset it or something from the registry ?!

  11. Have bug splatter on it!

  12. Thanks for this cool addon TheBen ! Keep the good work !

  13. SwiftTrans

    this application was configured to use a bundled java runtime environment but the runtime is missing or corrupted how do i get around this and cant you put a readme in the main package because theses files look crazy

  14. Love your work man but it would seem that the next version can’t come out soon enough

  15. Ways71

    Does the dirty windshield work without the Reshade/Graphics mod? The reshade/graphics mod lags on my PC (Using low end, so most graphic/reshade mods lag for me).

  16. This application was configured to use a java runtime environment, but the runtime is missing or corupted…

    I updated java and started ats in administrator mode but it doenst work


Leave a Reply

Your email address will not be published.

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


  • Login / Signup
  • If you like us…
  • Advertise